SOUI属性手册 20191126

SOUI

自愿打赏

我，手册作者，打钱

导言

本手册是基于soui3源码制作，收纳常用的一些控件属性，方便查阅，再也不用ctrl+f了。

骄傲的说，这是我用心制作的，很多内容都是自己通过琢磨源码才得出，为的是尽可能的准确和易懂。

但毕竟精力有限，仍有不少内容未被收纳，为了让大家尽快用上手册，就先发出来了。

后续有时间会不定期更新手册，如果有什么错误的地方，或者更好的意见，请发邮件给我!

控件列表

控件名 | 类名 | 描述
animateimg | SAnimateImgWnd | 图片动画控件
button | SButton | 按钮控件
calendar | SCalendar | 日历控件
caption | SCaption | 标题栏控件
check | SCheckBox | 复选框控件
combobase | SComboBase | 组合框基类
combobox | SComboBox | 组合框控件
comboview | SComboView | 组合框控件
dateTimePicker | SDateTimePicker | 日期选择控件
div | SPanel | 可滚动的容器控件
edit | SEdit | 输入框控件
font |  | 定义一组SOUI控件所使用的字体样式
group | SGroup | 分组控件
header | SHeaderCtrl | 表头控件
hr | SLine | 线条控件
icon | SIconWnd | 图标控件
img | SImageWnd | 图片控件
imgbtn | SImageButton | 图片按钮控件
link | SLink | 链接文本控件
listbox | SListBox | 列表框控件
listctrl | SListCtrl | 基础列表控件
listview | SListView | 自定义行内容的列表控件
mclistview | SMCListView | 自定义行内容的多列列表控件
progress | SProgress | 进度条控件
radio | SRadioBox | 单选框控件
radioGroup | SRadioGroup | 单选框分组控件
richedit | SRichEdit | 富文本编辑框控件
scrollview | SScrollView | 滚动控件
skin |  | 定义一组SOUI控件所使用的皮肤
soui | SHostWnd | SOUI界面的主节点，即每个对话框xml的根节点
splitcol | SSplitWnd_Col | 垂直分割容器
splitrow | SSplitWnd_Row | 水平分割容器
splitwnd | SSplitWnd | 分割窗口容器
tabctrl | STabCtrl | 标签页控件
text | SStatic | 静态文本控件
tileview | STileView | 平铺控件
toggle | SToggle | 状态切换控件，用于树节点的折叠与展开
treectrl | STreeCtrl | 基础树控件
treeview | STreeView | 自定义节点内容的树控件
window | SWindow | 窗口基础控件

作者：Seast

邮箱：10634796@企鹅.com

什么都略懂一点，生活更精彩一些。


控件列表

  • animateimg
  • button
  • calendar
  • caption
  • check
  • combobase
  • combobox
  • comboview
  • dateTimePicker
  • div
  • edit
  • font
  • group
  • header
  • hr
  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

animateimg

图片动画控件

自身属性

属性名 | 值类型 | 默认值 | 描述
skin | STRING |  | 图片皮肤
speed | UINT | 50 | 播放速度，即每帧间隔时间，单位毫秒
autoStart | BOOL | 1 | 是否自动播放
repeat | INT | -1 | 循环播放次数，-1表示无限循环
msgTransparent | INT | 1 | override，默认不接收鼠标和键盘消息

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示

属性说明：

1. BOOL类型：取值0或1

2. COLOR类型：取值可用格式#112233、#11223344、rgb(11,22,33)、rgba(11,22,33,44)、rgba2(11,22,33,44%)、rgba3(11,22,33,0.4)

3. FONT类型：一个或多个字体属性的组合，多个之间用逗号分隔，如：bold:1,underline:1


控件列表

  • caption
  • check
  • combobase
  • combobox
  • comboview
  • dateTimePicker
  • div
  • edit
  • font
  • group
  • header
  • hr
  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

button

按钮控件

自身属性

属性名 | 值类型 | 默认值 | 描述
accel | STRING |  | 快捷按键，如ctrl+d
animate | BOOL | 0 | 是否启用动画效果
animateStep | INT | 25 | 动画的步进值，即每帧增加的不透明度
disableAccelIfInvisible | BOOL | 0 | 控件隐藏时，是否也能用快捷按键触发
skin | STRING | _skin.sys.btn.normal | override，默认使用SOUI内置按钮皮肤
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • combobox
  • comboview
  • dateTimePicker
  • div
  • edit
  • font
  • group
  • header
  • hr
  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

calendar

日历控件

自身属性

属性名 | 值类型 | 默认值 | 描述
yearHeight | INT | 30 | 显示年月的高度
weekHeight | INT | 20 | 显示星期的高度
todayHeight | INT | 20 | 显示今天的高度
colorSelText | COLOR | #ffffff | 选中日期的文字颜色
colorOtherText | COLOR | #a0a0a0 | 其他日期的文字颜色
colorHoverText | COLOR | #007acc | 悬浮日期的文字颜色
colorSelBg | COLOR | #007acc | 选中日期的背景色
prevSkin | STRING | _skin.sys.btn.prev | 上个月日期的皮肤
nextSkin | STRING | _skin.sys.btn.next | 下个月日期的皮肤
daySkin | STRING |  | 日期的皮肤
weekSkin | STRING |  | 星期的皮肤
textSunday | STRING | 日 | 星期日的文字
textMonday | STRING | 一 | 星期一的文字
textTuesday | STRING | 二 | 星期二的文字
textWednesday | STRING | 三 | 星期三的文字
textThursday | STRING | 四 | 星期四的文字
textFriday | STRING | 五 | 星期五的文字
textSaturday | STRING | 六 | 星期六的文字
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • div
  • edit
  • font
  • group
  • header
  • hr
  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

caption

标题栏控件

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • group
  • header
  • hr
  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

check

复选框控件

自身属性

属性名 | 值类型 | 默认值 | 描述
skin | STRING | _skin.sys.checkbox | 图片皮肤
focusSkin | STRING | _skin.sys.focuscheckbox | 获得焦点时的皮肤
checked | BOOL | 0 | 是否勾选
align | STRING | left | override，默认文本向左对齐
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

combobase

组合框基类

自身属性

属性名 | 值类型 | 默认值 | 描述
btnSkin | STRING | _skin.sys.dropbtn | 下拉按钮皮肤
curSel | INT | -1 | 默认选中项的索引
dropDown | BOOL | 1 | 是否为纯下拉控件，为0时有编辑框
dropHeight | INT | 200 | 下拉框高度
animateTime | INT | 200 | 弹出下拉框的动画时长，单位毫秒
autoFitDropBtn | BOOL | 1 | 自适应下拉按钮大小
focusable | BOOL | 1 | override，默认可获取焦点
align | STRING | left | override，默认向左对齐
valign | STRING | middle | override，默认垂直居中

dropdownStyle

下拉框的样式

属性名 | 值类型 | 默认值 | 描述
... | ... | ... | SOUI窗口的属性集

editStyle

编辑框的样式

属性名 | 值类型 | 默认值 | 描述
... | ... | ... | edit的属性集

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

combobox

组合框控件

listStyle

下拉框的列表样式

属性名 | 值类型 | 默认值 | 描述
wndclass | STRING | listbox | 列表控件的类名，可使用自定义的新控件(必须是继承自SListBox)
... | ... | ... | listbox的属性集

继承自combobase

属性名 | 值类型 | 默认值 | 描述
btnSkin | STRING | _skin.sys.dropbtn | 下拉按钮皮肤
curSel | INT | -1 | 默认选中项的索引
dropDown | BOOL | 1 | 是否为纯下拉控件，为0时有编辑框
dropHeight | INT | 200 | 下拉框高度
animateTime | INT | 200 | 弹出下拉框的动画时长，单位毫秒
autoFitDropBtn | BOOL | 1 | 自适应下拉按钮大小
focusable | BOOL | 1 | override，默认可获取焦点
align | STRING | left | override，默认向左对齐
valign | STRING | middle | override，默认垂直居中

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

comboview

组合框控件

listStyle

下拉框的列表样式

属性名 | 值类型 | 默认值 | 描述
wndclass | STRING | listbox | 列表控件的类名，可使用自定义的新控件(必须是继承自SListBox)
... | ... | ... | listbox的属性集

继承自combobase

属性名 | 值类型 | 默认值 | 描述
btnSkin | STRING | _skin.sys.dropbtn | 下拉按钮皮肤
curSel | INT | -1 | 默认选中项的索引
dropDown | BOOL | 1 | 是否为纯下拉控件，为0时有编辑框
dropHeight | INT | 200 | 下拉框高度
animateTime | INT | 200 | 弹出下拉框的动画时长，单位毫秒
autoFitDropBtn | BOOL | 1 | 自适应下拉按钮大小
focusable | BOOL | 1 | override，默认可获取焦点
align | STRING | left | override，默认向左对齐
valign | STRING | middle | override，默认垂直居中

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

dateTimePicker

日期选择控件

自身属性

属性名 | 值类型 | 默认值 | 描述
btnSkin | STRING | _skin.sys.dropbtn | 下拉按钮皮肤
timeEnable | BOOL | 1 | 是否显示时分秒
dropWidth | INT | 220 | 下拉框的宽度
margin | INT|SIZE|RECT | 1 | override，默认边框大小
ncSkin | STRING | _skin.sys.border | override，默认边框皮肤
align | STRING | left | override，默认向左对齐
valign | STRING | middle | override，默认垂直居中
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

div

可滚动的容器控件

自身属性

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

edit

输入框控件

自身属性

属性名 | 值类型 | 默认值 | 描述
cueText | STRING |  | 无内容时的提示语
cueColor | COLOR | #cccccc | 提示语的文字颜色
rich | BOOL | 0 | override，默认纯文本输入
autoSel | BOOL | 1 | override，默认自动全选

继承自richedit

属性名 | 值类型 | 默认值 | 描述
style | DWORD | 0x80 | 样式集合，默认值是ES_LEFT|ES_AUTOHSCROLL
maxBuf | INT | 32767 | 最大字符数
rich | BOOL | 1 | 是否为富文本框
rtf | STRING |  | rtf资源文件
wordWrap | BOOL | 0 | 是否自动换行显示
allowBeep | BOOL | 0 | 是否启用响铃提醒
autoWordSel | BOOL | 1 | 是否自动选中单词
autoSel | BOOL | 0 | 获得焦点时是否自动全选
colorText | COLOR |  | 文字颜色
align | STRING | left | 对齐方式 left 向左 right 向右 center 居中
wantTab | BOOL | 0 | 是否捕获Tab按键，即允许插入制表符
wantReturn | BOOL | 0 | 是否捕获回车按键，即允许插入换行符
hscrollBar | BOOL | 0 | 是否显示水平滚动条
vscrollBar | BOOL | 0 | 是否显示垂直滚动条
autoHscroll | BOOL | 1 | 水平方向是否随输入自动滚动
autoVscroll | BOOL | 0 | 垂直方向是否随输入自动滚动
vcenter | BOOL | 1 | 单行模式时是否垂直居中显示
vertical | BOOL | 0 | 是否竖直显示
multiLines | BOOL | 0 | 是否支持多行文本
readOnly | BOOL | 0 | 是否只读
password | BOOL | 0 | 是否为密码输入框
passwordChar | CHAR | * | 为密码输入框时显示的密码字符
number | BOOL | 0 | 是否为数字输入框
transparent | BOOL | 0 | 是否背景透明
notifyChange | BOOL | 0 | 内容改变时是否发生发送通知
enableDragdrop | BOOL | 0 | 是否支持拖拽文件
disableCaret | BOOL | 0 | 是否隐藏输入光标
ncSkin | STRING | _skin.sys.border | override，默认边框皮肤
focusable | BOOL | 1 | override，默认可获取焦点
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

font

定义一组SOUI控件所使用的字体样式

自身属性

属性名 | 值类型 | 默认值 | 描述
name | STRING | default | 样式组合的名称
face | STRING | 宋体 | 字体名
charset | INT | 1 | 字符集，比如0是ANSI_CHARSET，134是GB2312_CHARSET
size | INT | 12 | 字体大小
adding | INT | 0 | 字体大小的附加值，正数表示字体更大，负数表示字体更小
weight | INT | 0 | 字体粗细，取值0-1000，400=normal，700=bold
bold | BOOL | 0 | 是否加粗，优先级低于weight
italic | BOOL | 0 | 是否斜体
underline | BOOL | 0 | 是否显示下划线
strike | BOOL | 0 | 是否显示删除线


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

group

分组控件

自身属性

属性名 | 值类型 | 默认值 | 描述
colorLine1 | COLOR | #f0f0f0 | 线条的第1种颜色
colorLine2 | COLOR | #a0a0a0 | 线条的第2种颜色
round | INT | 4 | 圆角半径
headerHeight | INT | 20 | 头部高度

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

header

表头控件

自身属性

属性名 | 值类型 | 默认值 | 描述
itemSkin | STRING | _skin.sys.header | 表头项的皮肤
sortSkin | STRING |  | 排序图标皮肤
fixWidth | BOOL | 0 | 是否宽度固定
itemSwapEnable | BOOL | 1 | 是否允许拖动调整位置
sortHeader | BOOL | 1 | 是否可以点击排序
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

hr

线条控件

自身属性

属性名 | 值类型 | 默认值 | 描述
colorLine | COLOR | #000000 | 线条颜色
lineColor | COLOR | #000000 | 同colorLine属性
lineSize | INT | 1 | 线条宽度
mode | STRING | horizontal | 显示方向 horizontal 水平 vertical 垂直 tilt 倾斜
lineStyle | STRING | solid | 线条样式 solid 实线 dash 短横虚线(------) dot 点号虚线(......) dashdot 一横一点交叉线(_._._.) dashdotdot 一横二点交叉线(_.._.._..)

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

icon

图标控件

自身属性

属性名 | 值类型 | 默认值 | 描述
src | STRING |  | 图标资源，如ICON_LOGO:16

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

img

图片控件

自身属性

属性名 | 值类型 | 默认值 | 描述
skin | STRING |  | 图片皮肤
iconIndex | INT | 0 | 使用索引指定的子图
tile | INT | 0 | 绘制方式 0 拉伸 1 不变 2 平铺
keepAspect | BOOL | 0 | 是否保持长宽比例不变
msgTransparent | INT | 1 | override，默认不接收鼠标和键盘消息

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

imgbtn

图片按钮控件

自身属性

属性名 | 值类型 | 默认值 | 描述
drawFocusRect | BOOL | 0 | override，默认不绘制焦点虚框

继承自button

属性名 | 值类型 | 默认值 | 描述
accel | STRING |  | 快捷按键，如ctrl+d
animate | BOOL | 0 | 是否启用动画效果
animateStep | INT | 25 | 动画的步进值，即每帧增加的不透明度
disableAccelIfInvisible | BOOL | 0 | 控件隐藏时，是否也能用快捷按键触发
skin | STRING | _skin.sys.btn.normal | override，默认使用SOUI内置按钮皮肤
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

link

链接文本控件

自身属性

属性名 | 值类型 | 默认值 | 描述
href | STRING |  | 目标链接
align | STRING | left | override，默认文本向左对齐

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

listbox

列表框控件

自身属性

属性名 | 值类型 | 默认值 | 描述
itemHeight | INT | 20 | 列表项的高度，即每行高度
itemSkin | STRING |  | 列表项的皮肤
iconSkin | STRING |  | 图标皮肤
colorItemBkgnd | COLOR |  | 列表项的背景色
colorItemBkgnd2 | COLOR |  | 偶数行的背景色
colorItemSelBkgnd | COLOR | rgba(57,145,209,255) | 选中行的背景色
colorItemHotBkgnd | COLOR | rgba(57,145,209,128) | 悬浮行的背景色
colorText | COLOR |  | 列表项的文字颜色
colorSelText | COLOR |  | 选中行的文字颜色
icon-x | INT | 0 | 图标绘制原点的x坐标
icon-y | INT | 0 | 图标绘制原点的y坐标
text-x | INT | 0 | 文本绘制原点的x坐标
text-y | INT | 0 | 文本绘制原点的y坐标
hotTrack | BOOL | 0 | 捕获悬浮事件
focusable | BOOL | 1 | override，默认可获取焦点

继承自scrollview

属性名 | 值类型 | 默认值 | 描述
origin-x | INT | 0 | 绘制原点的x坐标
origin-y | INT | 0 | 绘制原点的y坐标
viewSize | SIZE | 0,0 | 控件的大小
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

listctrl

基础列表控件

自身属性

属性名 | 值类型 | 默认值 | 描述
headerHeight | INT | 20 | 列表头的高度
itemHeight | INT | 20 | 列表项的高度，即每行高度
checkBox | BOOL | 0 | 是否有复选框
multiSelection | BOOL | 0 | 是否可选中多行
itemSkin | STRING |  | 列表项的皮肤
iconSkin | STRING |  | 图标皮肤
checkSkin | STRING | _skin.sys.checkbox | 复选框皮肤
colorItemBkgnd | COLOR | rgba(255,255,255,255) | 列表项的背景色
colorItemBkgnd2 | COLOR | rgba(226,226,226,255) | 偶数行的背景色
colorItemSelBkgnd | COLOR | rgba(57,145,209,255) | 选中行的背景色
colorItemHotBkgnd | COLOR | rgba(57,145,209,128) | 悬浮行的背景色
colorText | COLOR | rgba(0,0,0,255) | 列表项的文字颜色
colorSelText | COLOR | rgba(255,255,0,255) | 选中行的文字颜色
icon-x | INT | 0 | 图标绘制原点的x坐标
icon-y | INT | 0 | 图标绘制原点的y坐标
text-x | INT | 0 | 文本绘制原点的x坐标
text-y | INT | 0 | 文本绘制原点的y坐标
hotTrack | BOOL | 0 | 捕获悬浮事件
focusable | BOOL | 1 | override，默认可获取焦点
clipClient | BOOL | 1 | override，默认裁剪超出的内容

headerStyle

列表头的样式

属性名 | 值类型 | 默认值 | 描述
wndclass | STRING | header | 列表头的类名，可使用自定义的新控件(必须是继承自SHeaderCtrl)
... | ... | ... | header的属性集

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

listview

自定义行内容的列表控件

自身属性

属性名 | 值类型 | 默认值 | 描述
dividerSkin | STRING |  | 分隔线皮肤
dividerSize | INT | 0 | 分隔线宽度
wantTab | BOOL | 0 | 是否捕获Tab按键
focusable | BOOL | 1 | override，默认可获取焦点
updateInterval | INT | 40 | override，默认刷新间隔

template

列表项模板

属性名 | 值类型 | 默认值 | 描述
itemHeight | INT | 0 | 列表项的固定高度，不设置表示行高可变
defHeight | INT | 30 | 行高可变时的默认高度

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

mclistview

自定义行内容的多列列表控件

自身属性

属性名 | 值类型 | 默认值 | 描述
headerHeight | INT | 25 | 列表头的高度
dividerSkin | STRING |  | 分隔线皮肤
dividerSize | INT | 0 | 分隔线宽度
wantTab | BOOL | 0 | 是否捕获Tab按键
focusable | BOOL | 1 | override，默认可获取焦点
clipClient | BOOL | 1 | override，默认裁剪超出的内容
updateInterval | INT | 40 | override，默认刷新间隔

headerStyle

列表头的样式

属性名 | 值类型 | 默认值 | 描述
wndclass | STRING | header | 列表头的类名，可使用自定义的新控件(必须是继承自SHeaderCtrl)
... | ... | ... | header的属性集

template

列表项模板

属性名 | 值类型 | 默认值 | 描述
itemHeight | INT | 0 | 列表项的固定高度，不设置表示行高可变
defHeight | INT | 30 | 行高可变时的默认高度

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

progress

进度条控件

自身属性

属性名 | 值类型 | 默认值 | 描述
bkgndSkin | STRING |  | 背景皮肤
posSkin | STRING |  | 进度皮肤
min | INT | 0 | 最小进度值
max | INT | 100 | 最大进度值
value | INT | 0 | 当前进度值
vertical | BOOL | 0 | 是否竖直显示
showPercent | BOOL | 0 | 是否显示百分比
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

radio

单选框控件

自身属性

属性名 | 值类型 | 默认值 | 描述
skin | STRING | _skin.sys.radio | 图片皮肤
focusSkin | STRING | _skin.sys.focusradio | 获得焦点时的皮肤
checked | BOOL | 0 | 是否勾选
iconAlign | STRING | left | 图标水平对齐方式 left 向左 right 向右 center 居中
iconValign | STRING | middle | 图标垂直对齐方式 top 向上 bottom 向下 middle 居中
sep | INT | 4 | 图标和文本的间隔
align | STRING | left | override，默认文本向左对齐
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

radioGroup

单选框分组控件

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

richedit

富文本编辑框控件

自身属性

属性名 | 值类型 | 默认值 | 描述
style | DWORD | 0x80 | 样式集合，默认值是ES_LEFT|ES_AUTOHSCROLL
maxBuf | INT | 32767 | 最大字符数
rich | BOOL | 1 | 是否为富文本框
rtf | STRING |  | rtf资源文件
wordWrap | BOOL | 0 | 是否自动换行显示
allowBeep | BOOL | 0 | 是否启用响铃提醒
autoWordSel | BOOL | 1 | 是否自动选中单词
autoSel | BOOL | 0 | 获得焦点时是否自动全选
colorText | COLOR |  | 文字颜色
align | STRING | left | 对齐方式 left 向左 right 向右 center 居中
wantTab | BOOL | 0 | 是否捕获Tab按键，即允许插入制表符
wantReturn | BOOL | 0 | 是否捕获回车按键，即允许插入换行符
hscrollBar | BOOL | 0 | 是否显示水平滚动条
vscrollBar | BOOL | 0 | 是否显示垂直滚动条
autoHscroll | BOOL | 1 | 水平方向是否随输入自动滚动
autoVscroll | BOOL | 0 | 垂直方向是否随输入自动滚动
vcenter | BOOL | 1 | 单行模式时是否垂直居中显示
vertical | BOOL | 0 | 是否竖直显示
multiLines | BOOL | 0 | 是否支持多行文本
readOnly | BOOL | 0 | 是否只读
password | BOOL | 0 | 是否为密码输入框
passwordChar | CHAR | * | 为密码输入框时显示的密码字符
number | BOOL | 0 | 是否为数字输入框
transparent | BOOL | 0 | 是否背景透明
notifyChange | BOOL | 0 | 内容改变时是否发生发送通知
enableDragdrop | BOOL | 0 | 是否支持拖拽文件
disableCaret | BOOL | 0 | 是否隐藏输入光标
ncSkin | STRING | _skin.sys.border | override，默认边框皮肤
focusable | BOOL | 1 | override，默认可获取焦点
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

scrollview

滚动控件

自身属性

属性名 | 值类型 | 默认值 | 描述
origin-x | INT | 0 | 绘制原点的x坐标
origin-y | INT | 0 | 绘制原点的y坐标
viewSize | SIZE | 0,0 | 控件的大小
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

skin

定义一组SOUI控件所使用的皮肤

skinObjBase

皮肤基类，不能直接使用，都是用其子类

属性名 | 值类型 | 默认值 | 描述
name | STRING |  | 皮肤名称，同一窗口内必须唯一
alpha | UINT | 255 | 透明度(0-255)，0为完全透明
enableColorize | BOOL | 1 | 是否支持色调调节
checkAsPushdown | BOOL | 1 | 选中状态图是否使用按下状态图，即第3张子图 PS：8张子图的checkbox/radio皮肤，此属性值用0，其他默认即可
scale | INT | 100 | 缩放比例(百分比)

imglist : skinObjBase

图片皮肤

属性名 | 值类型 | 默认值 | 描述
src | STRING |  | 资源引用地址，即定义在uires.idx中的资源名 资源引用格式为type:name，如IMG:btn_close
tile | BOOL | 0 | 是否平铺 0 位伸 1 平铺
autoFit | BOOL | 1 | 自适应尺寸，即控件拉伸时是否变形铺满 0 不变形 1 变形铺满
vertical | BOOL | 0 | 子图是否垂直排列 0 水平排列 1 垂直排列
states | INT | 1 | 子图数目
filterLevel | STRING | none | 抗锯齿级别 none 不启用 low 低 medium 中 high 高

imgframe : imglist

九宫格图片皮肤

属性名 | 值类型 | 默认值 | 描述
margin | RECT | 0,0,0,0 | 九宫格四周边距，即边缘不拉伸的大小
left | INT | 0 | 九宫格左边距
top | INT | 0 | 九宫格上边距
right | INT | 0 | 九宫格右边距
bottom | INT | 0 | 九宫格下边距
margin-x | INT | 0 | 九宫格左右边距
margin-y | INT | 0 | 九宫格上下边距

scrollbar : imglist

滚动条皮肤

属性名 | 值类型 | 默认值 | 描述
margin | INT | 0 | 边缘不拉伸的大小
hasGripper | BOOL | 0 | 滑块上是否有帮手图案
hasInactive | BOOL | 0 | 是否有失活状态，主要针对两端的箭头 有失活状态时，图片必须有5行，否则可以是3行或4行

button : skinObjBase

按钮样式皮肤

属性名 | 值类型 | 默认值 | 描述
colorUp | COLOR | #eeeeee | 正常状态的渐变色上颜色
colorDown | COLOR | #d6d6d6 | 正常状态的渐变色下颜色
colorUpHover | COLOR | #eeeeee | 悬浮状态的渐变色上颜色
colorDownHover | COLOR | #e0e0e0 | 悬浮状态的渐变色下颜色
colorUpPush | COLOR | #cecece | 按下状态的渐变色上颜色
colorDownPush | COLOR | #c0c0c0 | 按下状态的渐变色下颜色
colorUpDisable | COLOR | #8e8e8e | 禁用状态的渐变色上颜色
colorDownDisable | COLOR | #808080 | 禁用状态的渐变色下颜色
colorBorder | COLOR | #707070 | 正常状态的边框颜色
colorBorderHover | COLOR |  | 悬浮状态的边框颜色
colorBorderPush | COLOR |  | 按下状态的边框颜色
colorBorderDisable | COLOR |  | 禁用状态的边框颜色
cornerRadius | INT | 2 | 圆角半径(优先级低于cornerPercent属性)
cornerPercent | FLOAT | 0.0 | 圆角百分比，0.5即是半圆

colorrect : skinObjBase

颜色样式皮肤

属性名 | 值类型 | 默认值 | 描述
normal | COLOR | #ffffff | 正常状态的颜色
hover | COLOR |  | 悬浮状态的颜色
pushdown | COLOR |  | 按下状态的颜色
disable | COLOR |  | 禁用状态的颜色
normalBorder | COLOR |  | 正常状态的边框颜色
hoverBorder | COLOR |  | 悬浮状态的边框颜色
pushdownBorder | COLOR |  | 按下状态的边框颜色
disableBorder | COLOR |  | 禁用状态的边框颜色
borderWidth | INT | 0 | 边框大小
cornerRadius | INT | 0 | 圆角半径(优先级低于cornerPercent属性)
cornerPercent | FLOAT | 0.0 | 圆角百分比，0.5即是半圆

gradation : skinObjBase

渐变色样式皮肤

属性名 | 值类型 | 默认值 | 描述
colorFrom | COLOR |  | 渐变起始颜色
colorTo | COLOR |  | 渐变终止颜色
vertical | BOOL | 1 | 渐变方向 0 水平方向 1 垂直方向


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

soui

SOUI界面的主节点，即每个对话框xml的根节点

自身属性

属性名 | 值类型 | 默认值 | 描述
title | STRING |  | 窗口标题
trCtx | STRING |  | xml的翻译名称，在语言翻译时作为context使用
width | INT | -1 | 窗口预设的宽度，-1表示根据内容自适应宽度
height | INT | -1 | 窗口预设的高度，-1表示根据内容自适应高度
minSize | SIZE | 0,0 | 窗口最小尺寸，拉伸窗口时不会小于该尺寸
margin | RECT | 0,0,0,0 | 鼠标拉伸窗口的感应区大小
maxInset | RECT | 0,0,0,0 | 窗口最大化时超出屏幕的边缘大小 经测试，WS_OVERLAPPED的窗口该属性无效
resizable | BOOL | 0 | 窗口是否可改变大小
wndStyle | DWORD | 0 | 窗口样式
wndStyleEx | DWORD | 0 | 窗口扩展样式
wndType | STRING | undefine | 窗口类型 undefine 未定义 appMain 主窗口(关闭主窗口时程序退出) normal 常规窗口
appWnd | BOOL | 0 | 窗口是否为应用窗口，对应WS_EX_APPWINDOW扩展样式 应用窗口会在任务栏上显示按钮，通常用于主窗口
toolwindow | BOOL | 0 | 窗口是否为工具窗口，对应WS_EX_TOOLWINDOW扩展样式 工具窗口不会在任务栏上显示按钮，通常用于弹出窗口
translucent | BOOL | 0 | 窗口是否支持透明，启用后子窗口不能使用真窗口
alpha | UINT | 255 | 窗口的透明度(0-255)，0为完全透明
sendWheel2Hover | BOOL | 0 | 是否发送鼠标滚轮消息到hover窗口
smallIcon | STRING |  | 标题栏小图标，格式：iconname:size 如ICON_LOGO:16
bigIcon | STRING |  | 标题栏大图标，格式：iconname:size 如ICON_LOGO:32
allowSpy | BOOL | 1 | 是否允许SouiSpy探测窗口


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

splitcol

垂直分割容器

自身属性

属性名 | 值类型 | 默认值 | 描述
sepSkin | STRING | _skin.sys.split.vert | override，默认分割条皮肤
vertical | BOOL | 1 | override，默认垂直分割

继承自splitwnd

属性名 | 值类型 | 默认值 | 描述
sepSize | INT | 5 | 分割条的宽度
sepSkin | STRING |  | 分割条的皮肤
adjustable | BOOL | 1 | 是否支持拖动调节窗口大小
vertical | BOOL | 1 | 分割(条)方向 0 水平 1 垂直

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

splitrow

水平分割容器

自身属性

属性名 | 值类型 | 默认值 | 描述
sepSkin | STRING | _skin.sys.split.horz | override，默认分割条皮肤
vertical | BOOL | 0 | override，默认水平分割

继承自splitwnd

属性名 | 值类型 | 默认值 | 描述
sepSize | INT | 5 | 分割条的宽度
sepSkin | STRING |  | 分割条的皮肤
adjustable | BOOL | 1 | 是否支持拖动调节窗口大小
vertical | BOOL | 1 | 分割(条)方向 0 水平 1 垂直

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

splitwnd

分割窗口容器

自身属性

属性名 | 值类型 | 默认值 | 描述
sepSize | INT | 5 | 分割条的宽度
sepSkin | STRING |  | 分割条的皮肤
adjustable | BOOL | 1 | 是否支持拖动调节窗口大小
vertical | BOOL | 1 | 分割(条)方向 0 水平 1 垂直

pane : window

分割的子窗口

属性名 | 值类型 | 默认值 | 描述
idealSize | INT | 20 | 理想大小
minSize | INT | 0 | 最小大小
maxSize | INT | 10000 | 最大大小
priority | INT | 0 | 窗口优先级，值越大优先级越高，窗口越先达到理想大小

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

tabctrl

标签页控件

自身属性

属性名 | 值类型 | 默认值 | 描述
curSel | INT | 0 | 默认显示页的索引
tabSize | SIZE | -1,-1 | 标签按钮的大小
tabWidth | INT | -1 | 标签按钮的宽度
tabHeight | INT | -1 | 标签按钮的高度
tabPos | INT | 0 | 标签按钮的起始位置
tabInterSize | INT | 0 | 标签按钮的间距
tabSkin | STRING | _skin.sys.tab.page | 标签按钮的皮肤
tabInterSkin | STRING |  | 标签按钮的分隔皮肤
iconSkin | STRING |  | 标签图标皮肤
frameSkin | STRING |  | 页面皮肤
icon-x | INT | 0 | 标签图标起始位置x坐标
icon-y | INT | 0 | 标签图标起始位置y坐标
text-x | INT | -1 | 标签文本起始位置x坐标
text-y | INT | -1 | 标签文本起始位置y坐标
tabAlign | STRING | top | 标签对齐方式 top 向上 left 向左 bottom 向下 right 向右
textDir | STRING | horizontal | 文本显示方向 hori|horizontal 水平显示 vert|vertical 竖直显示
animateSteps | INT | 0 | 页面切换动画帧数
animateType | INT | 0 | 页面切换动画类型 0 背景跟着动 1 背景不动
focusable | BOOL | 1 | override，默认可获取焦点

page : window

标签页控件的页面

属性名 | 值类型 | 默认值 | 描述
title | STRING |  | 页面的标题
iconIndex | INT | -1 | 页面的图标
visible | BOOL | 0 | override，页面默认隐藏

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

text

静态文本控件

自身属性

属性名 | 值类型 | 默认值 | 描述
interHeight | INT | 5 | 行间距
wordBreak | BOOL | 0 | 换行处是否保持单词完整 0 允许在单词内换行 1 保持单词在同一行
align | STRING | left | override，默认文本向左对齐
msgTransparent | INT | 1 | override，默认不接收鼠标和键盘消息

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

tileview

平铺控件

自身属性

属性名 | 值类型 | 默认值 | 描述
marginSize | INT | 0 | 子项的间距
wantTab | BOOL | 0 | 是否捕获Tab按键
focusable | BOOL | 1 | override，默认可获取焦点
updateInterval | INT | 40 | override，默认刷新间隔

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

toggle

状态切换控件，用于树节点的折叠与展开

自身属性

属性名 | 值类型 | 默认值 | 描述
skin | STRING | _skin.sys.tree.toggle | override，默认皮肤

继承自check

属性名 | 值类型 | 默认值 | 描述
skin | STRING | _skin.sys.checkbox | 图片皮肤
focusSkin | STRING | _skin.sys.focuscheckbox | 获得焦点时的皮肤
checked | BOOL | 0 | 是否勾选
align | STRING | left | override，默认文本向左对齐
focusable | BOOL | 1 | override，默认可获取焦点

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

treectrl

基础树控件

自身属性

属性名 | 值类型 | 默认值 | 描述
indent | INT | 18 | 内间距，即文本的绘制起始位置
itemHeight | INT | 20 | 节点的高度
itemMargin | INT | 4 | 节点的外边距
checkBox | BOOL | 0 | 是否显示复选框
rightClickSel | BOOL | 0 | 是否右击选中行
itemBkgndSkin | STRING |  | 节点背景皮肤
itemSelSkin | STRING |  | 节点选中时皮肤
iconSkin | STRING |  | 节点图标皮肤
checkSkin | STRING | _skin.sys.tree.checkbox | 复选框皮肤
toggleSkin | STRING | _skin.sys.tree.toggle | 折叠按钮皮肤
colorItemBkgnd | COLOR | #ffffff | 节点背景色
colorItemSelBkgnd | COLOR | #000088 | 节点选中时背景色
colorItemText | COLOR | #000000 | 节点文字颜色
colorItemSelText | COLOR | #ffffff | 节点选中时的文字颜色
hasLines | BOOL | 0 | 是否绘制连接线条

继承自scrollview

属性名 | 值类型 | 默认值 | 描述
origin-x | INT | 0 | 绘制原点的x坐标
origin-y | INT | 0 | 绘制原点的y坐标
viewSize | SIZE | 0,0 | 控件的大小
clipClient | BOOL | 1 | override，默认裁剪超出的内容

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

treeview

自定义节点内容的树控件

自身属性

属性名 | 值类型 | 默认值 | 描述
indent | INT | 0 | 内间距，即节点的绘制起始位置
wantTab | BOOL | 0 | 是否捕获Tab按键
focusable | BOOL | 1 | override，默认可获取焦点

继承自div

属性名 | 值类型 | 默认值 | 描述
sbSkin | STRING | _skin.sys.scrollbar | 滚动条皮肤
sbArrowSize | INT | 0 | 滚动条两端箭头的大小
sbWid | INT | 0 | 滚动条的宽度
sbEnable | INT | 3 | 滚动条是否可操作 0 不可操作 1 水平滚动条可操作 2 垂直滚动条可操作 3 均可操作
scrollSpeed | INT | 10 | 滚动速度，即每次滚动的距离
sbLeft | INT | 0 | 滚动条距离左边距离
sbRight | INT | 0 | 滚动条距离右边距离
sbTop | INT | 0 | 滚动条距离上边距离
sbBottom | INT | 0 | 滚动条距离下边距离
updateInterval | INT | 0 | 刷新间隔，单位毫秒

继承自window

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示


控件列表

  • icon
  • img
  • imgbtn
  • link
  • listbox
  • listctrl
  • listview
  • mclistview
  • progress
  • radio
  • radioGroup
  • richedit
  • scrollview
  • skin
  • soui
  • splitcol
  • splitrow
  • splitwnd
  • tabctrl
  • text
  • tileview
  • toggle
  • treectrl
  • treeview
  • window

window

窗口基础控件

自身属性

属性名 | 值类型 | 默认值 | 描述
id | INT | 0 | 控件ID
name | STRING |  | 控件名称
layout | STRING | souiLayout | 布局样式，支持3种布局 souiLayout 相对布局 gridLayout 网格布局 linearLayout 线性布局(分vbox、hbox两种)
class | STRING |  | 属性集合的名称，定义于style中，类比HTML的class属性
skin | STRING |  | 皮肤样式的名称，定义于skin中
ncSkin | STRING |  | 非客户区的皮肤
text | STRING |  | 显示的文本
tip | STRING |  | 鼠标悬浮时的提示语
trCtx | STRING |  | 翻译名，为空时使用<soui>的trCtx属性值
data | INT | 0 | 指定一个附加的数据，可通过GetUserData获取
enable | BOOL | 1 | 控件是否可用
focusable | BOOL | 0 | 控件是否可获取焦点
visible | BOOL | 1 | 控件是否可见
show | BOOL | 1 | 同visible属性
display | BOOL | 1 | 隐藏时是否占位 0 不占位 1 占位
maxWidth | INT | -1 | 根据内容自适应大小时的最大宽度
float | BOOL | 0 | 位置是否固定不动
alpha | UINT | 255 | 控件的透明度(0-255)，0为完全透明
layeredWindow | BOOL | 0 | 是否为分层窗口
msgTransparent | BOOL | 0 | 鼠标消息穿透，开启后控件接收不到鼠标和键盘消息
trackMouseEvent | BOOL | 0 | 鼠标事件跟踪，捕获子控件的鼠标消息
clipClient | BOOL | 0 | 限制内容只绘制在客户区，开启后超出控件边界的内容会被裁剪掉
cache | BOOL | 0 | 绘制缓存 0 无缓存，每次刷新时发送WM_PAINT消息重绘 1 创建绘制缓存，只有自己窗口更新才重绘，否则直接调用缓存绘制
drawFocusRect | BOOL | 1 | 是否绘制焦点虚框
multiLines | BOOL | 0 | 是否支持多行显示
align | STRING | center | 文本水平对齐方式 left 向左 right 向右 center 居中
valign | STRING | center | 文本垂直对齐方式 top 向上 bottom 向下 middle 居中
colorBkgnd | COLOR |  | 背景颜色
colorBorder | COLOR |  | 边框颜色
font | FONT |  | 正常状态的文本字体
fontHover | FONT |  | 悬浮状态的文本字体
fontPush | FONT |  | 按下状态的文本字体
fontDisable | FONT |  | 禁用状态的文本字体
colorText | COLOR |  | 正常状态的文本颜色
colorTextHover | COLOR |  | 悬浮状态的文本颜色
colorTextPush | COLOR |  | 按下状态的文本颜色
colorTextDisable | COLOR |  | 禁用状态的文本颜色
margin | INT|SIZE|RECT | 0 | 外边距(非客户区)的大小
margin-x | INT | 0 | 左右外边距
margin-y | INT | 0 | 上下外边距
padding | INT|SIZE|RECT | 0 | 内边距的大小
padding_left | INT | 0 | 左内边距
padding_top | INT | 0 | 上内边距
padding_right | INT | 0 | 右内边距
padding_bottom | INT | 0 | 下内边距
inset | INT|SIZE|RECT | 0 | 同padding属性
cursor | STRING | arrow | 鼠标停留时的光标资源，可取值有： arrow、hand、cross、wait、size、help等
dotted | BOOL | 1 | 文本超出边界时，是否使用末尾...显示

souiLayout

相对布局，默认的布局，也是最常用的

属性名 | 值类型 | 默认值 | 描述
pos | SIZE|RECT | 0,0 | 控件位置，支持多种写法，详细请移步论坛
width | INT | -1 | 控件的宽度 -1 | wrapContent 根据内容自适应宽度 -2 | full | matchParent 匹配父控件的宽度
height | INT | -1 | 控件的高度 -1 | wrapContent 根据内容自适应高度 -2 | full | matchParent 匹配父控件的高度
size | SIZE | -1,-1 | 控件大小，即宽和高
offset | SIZE | 0,0 | 控件偏移百分比，数值为浮点型 如-0.5,0表示向左偏移控件宽度一半的距离

gridLayout

网格布局

属性名 | 值类型 | 默认值 | 描述
rowCount | INT | -1 | 行数
columnCount | INT | -1 | 列数
interval | INT | 0 | 间距
xInterval | INT | 0 | 水平间距
yInterval | INT | 0 | 垂直间距
gravity | STRING | center | 排列方式 left | top 向左&向上 right | bottom 向右&向下 center 居中 fill 填满
xGravity | STRING | center | 水平排列方式
yGravity | STRING | center | 垂直排列方式

gridLayoutParam

网格布局的子控件样式，即每个格子的属性

属性名 | 值类型 | 默认值 | 描述
width | INT | -1 | 格子的宽度 -1 | wrapContent 根据内容自适应宽度 -2 | matchParent 匹配父控件的宽度
height | INT | -1 | 格子的高度 -1 | wrapContent 根据内容自适应高度 -2 | matchParent 匹配父控件的高度
size | SIZE | -1,-1 | 格子的大小，即宽和高
rowSpan | INT | 1 | 格子占用的行数，类比HTML的rowspan属性
columnSpan | INT | 1 | 格子占用的列数，类比HTML的colspan属性
layout_gravity | STRING |  | 格子的排列方式 left | top 向左&向上 right | bottom 向右&向下 center 居中 fill 填满
layout_xGravity | STRING |  | 格子的水平排列方式
layout_yGravity | STRING |  | 格子的垂直排列方式
rowWeight | FLOAT | 0.0 | 格子高度的加权值
columnWeight | FLOAT | 0.0 | 格子宽度的加权值

linearLayout

线性布局

属性名 | 值类型 | 默认值 | 描述
orientation | STRING |  | 排列方向 horizontal 水平排列 vertical 垂直排列
gravity | STRING |  | 排列方式 left | top 向左/向上 right | bottom 向右/向下 center 居中
interval | INT | 0 | 间距

hbox : linearLayout

水平线性布局

属性名 | 值类型 | 默认值 | 描述
orientation | STRING | horizontal | override，默认水平排列

vbox : linearLayout

垂直线性布局

属性名 | 值类型 | 默认值 | 描述
orientation | STRING | vertical | override，默认垂直排列